読者です 読者をやめる 読者になる 読者になる

hidemium's blog

日々学んだことをアウトプットする。

Rails のバージョンを指定してインストールする

インストールを行なうと「file 'lib' not found」というエラーメッセージが表示されるので、先にRDoc(Documentation from Ruby Source Files)をインストールしておきます。

$ gem search -r rails
$ gem install rdoc
$ gem install rails --version="3.2.17" #指定バージョンをインストール
$ gem install rails --version="~>3.2.0" #3.2.X系の最新バージョンをインストール
$ gem install rails --version="~>3.0" #3.X系の最新バージョンをインストール
$ rails -v

rails -v」でバージョンを確認しようとしたところ、パスが通ってないのか「コマンドが見つかりません」というエラーメッセージが表示されるので、ログインし直すとrailsのバージョンが表示されました。